BlackTDN Search

terça-feira, 13 de março de 2018

BlackTDN :: Entendendo o Cálculo de Pensão Alimentícia no Totvs Microsiga Protheus

Um dos cálculos da Folha de Pagamento que geram dúvidas e discórdias é o “Famigerado” Cálculo de Pensão Alimentícia.
O sistema TOTVS Microsiga Protheus faz o cálculo na Forma da Lei e, como poderão verificar, em conformidade com a “Consulta 354 – Cosit” (abaixo Transcrita).
SC_Cosit_n_354-2014-page-001 SC_Cosit_n_354-2014-page-002 SC_Cosit_n_354-2014-page-003 SC_Cosit_n_354-2014-page-004 SC_Cosit_n_354-2014-page-005 SC_Cosit_n_354-2014-page-006
Dessa forma, e para facilitar o entendimento e a conferência dos valores de IRF e Pensão Alimentícia calculados pelo sistema, mostrarei um exemplo de como implementar o cálculo no Microsoft Excel.
1) Preparando o Ambiente:
  1. Abra o Microsoft Excel;
  2. Cria as “abas” (worksheets):
    1. Funcionários;
    2. Lançamento;
    3. Cálculo;
    4. Tabela IR;
    5. Eventos;
  3. Na “aba” Funcionários, crie as seguintes colunas:
    1. “ID”;
    2. “Nome”;
    3. “% Pensao”;
    4. image
  4. Na “aba” Lançamentos, crie as seguintes colunas:
    1. “ID”
    2. “Funcionário”;
    3. “Evento”;
    4. “Descrição”;
    5. “Valor”;
    6. “IRRF”;
    7. “Pensão”;
    8. image
  5. Na “aba” Cálculo, crie as seguintes colunas:
    1. “ID”;
    2. “Funcionário”;
    3. “Somar Base IRRF”;
    4. “Base IRRF”;
    5. “% IRRF”;
    6. “Dedução”;
    7. “IRRF”;
    8. “Somar Base Pensão”;
    9. “Base Pensão”;
    10. “% Pensão”;
    11. “Pensão”;
    12. image
  6. Na “aba” Tabela IR, crie as seguintes colunas:
    1. “Faixa”;
    2. “Faixa Inicial”;
    3. “Faixa Final”;
    4. “Alíquota (%)/Parcela a Deduzir”;
    5. image
  7. E, finalmente, na “aba” Eventos crie as colunas:
    1. “Evento”;
    2. “Descrição”.
2) Configurando a Planilha:
  1. Na “aba” Tabela IR, carregue os dados conforme Tabela fornecida pela Receita Federal;
  2. Na “aba” Eventos, Informe os “eventos” que serão utilizados;
  3. Na “aba” Lançamento:
    1. Inclua, na primeira linha digitável da coluna “Funcionário”, a seguinte fórmula para obter o “Nome” do funcionário: =PROCV(A2;Funcionários!A:B;2;FALSO)
      1. Criar uma relação entre o “ID” do funcionário (Célula A2) com o “ID” da “aba” Funcionários retornando o “Nome do Funcionário”.
    2. Inclua, na primeira linha digitável da coluna “Descrição”, a seguinte fórmula para obter a “Descrição” do evento: =PROCV(C2;Eventos!A:B;2;FALSO)
      1. Criar uma relação entre o “ID” do Evento (Célula C2) com o “ID” da “aba” Eventos retornando a “Descrição do Evento”.
  4. Na “aba” Cálculo:
    1. Inclua, na primeira linha digitável da coluna “Funcionário”, a seguinte fórmula para obter o “Nome” do funcionário: =PROCV(A2;Funcionários!A:B;2;FALSO)
      1. Criar uma relação entre o “ID” do funcionário (Célula A2) com o “ID” da “aba” Funcionários retornando o “Nome do Funcionário”.
    2. Inclua, na primeira linha digitável da coluna “Somar Base IRRF”, a seguinte fórmula para obter a soma dos valores que comporão a Base para o cálculo do IR: =SOMASES(Table27[Valor];Table27[ID];Table1[ID];Table27[IRRF];1)
      1. Somar todos os “Eventos” informados na “aba” Lançamento que incidam IRRF;
    3. Inclua, na primeira linha digitável da coluna “Base IRRF”, a seguinte fórmula para obter a “Base IRRF” subtraida do valor da “Pensão”: =[Somar Base IRRF]-[Pensão]
      1. Obter a base para o Cálculo do IRRF subtraido do valor da Pensão
    4. Inclua, na primeira linha digitável da coluna “% IRRF”, a seguinte fórmula para obter o “% IRRF”: =PROCV([Base IRRF];Tabela9[[Faixa Inicial]:[Alíquota (%)]];3;VERDADEIRO)
      1. Procura, na tabela de IRRF, a Faixa que corresponde ao valor inforado como Base de IRRF e retorna a “Alíquota” correspondente;
    5. Inclua, na primeira linha digitável da coluna “Dedução”, a seguinte fórmula para obter a “Parcela a Deduzir”: =PROCV([Base IRRF];Tabela11[[Faixa Inicial]:[Parcela a Deduzir]];3;VERDADEIRO)
      1. Procura, na tabela de IRRF, a Faixa que corresponde ao valor inforado como Base de IRRF e retorna o “Valor da Parcela a Deduzir” correspondente;
    6. Inclua, na primeira linha digitável da coluna “IRRF”, a seguinte fórmula para obter o valor do “IRRF”: =[Base IRRF]*[% IRRF]-[Dedução]
      1. Apura o Valor do IRRF
    7. Inclua, na primeira linha digitável da coluna “Somar Base Pensão”, a seguinte fórmula para obter a soma dos valores que comporão a Base para o cálculo da Pensão: =SOMASES(Table27[Valor];Table2[ID];Table1[ID];Table27[Pensao];1)
      1. Somar todos os “Eventos” informados na “aba” Lançamento que incidam Pensão;
    8. Inclua, na primeira linha digitável da coluna “Base Pensão”, a seguinte fórmula para obter a “Base da Pensão” subtraida do “IRRF”: =[Somar Base Pensão]-[IRRF]
      1. Obter a base para o Cálculo da Pensão subtraida do valor do IRRF
      2. Obs.: Criamos uma “Referência Cruzada Aqui”image . Essa é a parte importante para o correto cálculo do IR e da Pensão. Necessitamos da “Referência Cruzada” pois necessitamos de “múltiplas iterações no cálculo” uma vez que: Para a apuração do IRRF tenho que deduzir e Pensão e Vice-e-versa. Neste caso, faremos a seguinte alteração nas configurações do Microsoft Excel:
        1. Clique em “Arquivo\Opções” image ;
        2. Selecione “Fórmulas” image
        3. Marque a opção “Habilitar cálculo iterativo” image  (maiores referências em: XL97: Usando iterações e alteração máxima em cálculos)
    9. Inclua, na primeira linha digitável da coluna “% Pensão”, a seguinte fórmula para obter o “% para o cálculo da Pensão”: =PROCV(A2;Funcionários!A:C;3;FALSO)
    10. e, finalmente, inclua, na primeira linha digitável da coluna “Pensão”, a seguinte fórmula para obter o valor da “Pensão”: =[Base Pensão]*[% Pensão]
3) Populando e calculando os valores
  1. Na “aba” Funcionários informe o “ID”, “Nome” e “% Pensão”;
  2. Na “aba” Lançamento, informe os valores que comporão a Base para o Cálculo do IRRF e da Pensão;
    1. Obs.: utilizaremos os seguintes “flags”: 1-Incide;0-Não Incide (Tanto para IRRF quanto para Pensão);
    2. Para valores a deduzir, informe-os como “Negativos” Ex: –1;
  3. Observe o Cálculo na “aba” Cálculo.
4) A Prova dos “9”:
  1. Utilize a seguinte fórmula para validar o cálculo da Pensão: image
    1. Onde:
      1. image
      2. image
Ex.:

P=(j/(1-(i*j)))*(BCP-(i*BCIR)+PD)

Onde:

P=Pensão Alimentícia
j=% Desconto da Pensão
i=% Tabela Progressiva IR
BCP=Base Cálculo da Pensão
BCIR=Base Cálculo do IR
PD=Parcela a Deduzir IR

Substituindo os valores temos:

BCP=8.620,35
BCIR=9.489,01
j=0,40
i=0,2750
PD=869,36

Calculando: P=(j/(1-(i*j)))*(BCP-(i*BCIR)+PD)

P=(0,40/(1-(0,2750*0,40)))*(8.620,35-(0,2750*9.489,01)+869,36)

P=3.092,24


Descrição
Valor
IRRF
Pensão
SALARIO MENSAL 10.000,00 
1
1
ADICIONAL NOTURNO 250,03 
1
0
DSR ADS NOTURNO 60,01 
1
0
ASSISTENCIA MEDICA -414,32 
0
1
ASSISTENCIA ODONTOLOGICA -144,30 
0
1
INSS SALARIO -621,03 
1
1
PREVIDENCIA -200,00 
1
1

Somar Base IRRF
Base IRRF
% IRRF
Dedução
IRRF
Somar Base Pensão
Base Pensão
% Pensão
Pensão
Liquido Pensão
Liquido IR
9.489,01
6.396,77
0,2750
869,36
889,75
8.620,35
7.730,60
0,40
3.092,24
3.092,24
889,75


Fórmula (P) (P) (j) (i) (PD) (BCP) (BCIR)
P=(j/(1-(i*j)))*(BCP-(i*BCIR)+PD) 3.092,24 0,40 0,2750 869,36 8.620,35 9.489,01
P=Pensão Alimentícia
j=% Desconto da Pensão
i=% Tabela Progressiva IR
BCP=Base Cálculo da Pensão
BCIR=Base Cálculo do IR
PD=Parcela a Deduzir IR


Para obter a planilha utilizada no exemplo clique aqui.
A íntegra da "Solução de Consulta nº 354 – Cosit: PENSÃO ALIMENTÍCIA. CÁLCULO SOBRE A REMUNERAÇÃO LÍQUIDA DE IMPOSTO SOBRE A RENDA" poderá ser obitida a partir daqui.
[]s
иαldσ dj